Back to overview
Resolved

Network review

Jun 26, 2026 at 6:30pm UTC  –  Jun 26, 2026 at 10:30pm UTC
Affected services
axtazer.me
Short URL
Jellyfin
Panel | Pelican
API | Wings
Private website
Nextcloud

Resolved
Jun 26, 2026 at 10:30pm UTC

Maintenance ended

Created
Jun 26, 2026 at 6:30pm UTC

Network down